Open webOS will not support existing webOS devices | webOS Nation

Open webOS will not support existing webOS devices

by Derek Kessler Tue, 31 Jul 2012 3:52 pm EDT

Open webOS will not support existing webOS devices

In addition to today's release of the core apps  and LunaSysMgr for Open webOS, we got some news that's both surprising and heartbreaking: Open webOS will not support existing webOS devices. According to today's blog post on the Open webOS Project Blog, the development team is "aiming for support on future hardware platforms where SoC's [system-on-chips] support Linux 3.3+ kernel and where open source replacements for proprietary components are integrated. Existing devices cannot be support because of those many proprietary components, including graphics, networking and lack of drivers for a modern kernel".

Feel like you just got punched in the gut? Yeah, us to. Despite being a modification and enhancement of the existing webOS, Open webOS will not be able to support any existing webOS devices, including the most-recently-released TouchPad and Pre3. Reasoning? Their processors don't support the Linux Standard Kernel nor are there complete open source replacements for hardware component drivers. If you were hoping to run Open webOS on your TouchPad, you're going to have to rely on the community to get it done, not HP.

We're not at all thrilled with this decision. HP already has access to the proprietary drivers for the TouchPad, Pre3, and a whole slew of webOS devices and could put together a release of Open webOS for those devices. But yet again, HP's made the decision to neglect off a small but loyal customer base in favor of pursuing bigger dreams. We understand that the resources available to the Open webOS team are limited - certainly much more limited than they were eighteen months ago when HP decided not to bother finishing a webOS 2.0 update for older Pre and Pixi devices and buried it under the news of the TouchPad, Veer, and Pre3 announcements - but this pattern of dumping on those who have stuck with the platform isn't the makings for continuing loyalty. People love webOS, but they can only put up with being slighted for so long.

As pointed out in the blog post, there is at least the webOS Community Edition release for us to tinker with for existing devices (i.e. the TouchPad), which included the older version of the LunaSysMgr as released in webOS 3.0.5. Today's announcement crystallizes the Community Edition's reason for existence: it was a pre-appeasment meant to be there, ready for this news, so HP can say, "But we already gave you that! Isn't that enough?"

There are two things to keep in mind moving forward. One: there's a large and growing number of Android devices out there that offer support for the Linux Standard Kernel 3.3, and given the number of devices supported by the open source CyanogenMod Android project there are plenty of drivers available for those components. Two: The webOS homebrew community cannot and will not be held back. They've already started working on the webOS Community Edition release of LunaSysMgr to see how well they can get it to work on the Pre3, and it'll only be a matter of time before they figure out how to get the goodness of Open webOS to work on our current webOS devices, HP be damned.