Preware update integrates and enhances patching process | webOS Nation
 
 

Preware update integrates and enhances patching process 60

by Derek Kessler Fri, 09 Oct 2009 6:15 pm EDT

Preware v. 0.9.3 A fresh Preware update (v 0.9.3) has landed and it brings new features to the webOS patching game. Most notably, Preware now can handle the removal and updating of patches (though the update function is just an automatic removal/install) and has integrated webOS Internals’ newly updated patch feed.

To upgrade to the new Preware you must first update the Package Manager Service, followed by Preware itself. And then to transition to the new patch feed (autopatch is now obsolete) you should download the Emergency Patch Recovery tool patch to wipe away all installed patches, remove your previously installed virtual keyboard, and install Luna Manager to easily restart the requisite parts of webOS to update your actions. And then reinstall all the patches - it’s a slight hassle, but that is the price of living on the edge. Preware developer Rod has posted very concise instructions in our forums.

Speaking of our forums, PreCentral has a new subforum under webOS Development: webOS patches. Here you can discuss what patches you’d like to see, report patch bugs, get help, contribute to development, and more.

Category:

60 Comments

Better run the ERD to avoid the pesky error 4s. I ran ERD before updating preware and package installer and put my patches in just fine :) Loving this not having to restart luna for every single patch till your done with the install selection. Jolly good show!!

Now would like the ability to update themes rather than uninstall, restart luna, and then install updated theme :)

Ya I followed the instructions and then my phone just stayed offline. so I had to do a reset of the phone. oh well, that's life, glad palm backs stuff up

What is ERD and where can I find this? I thought it was Emergency Patch Recovery, but I guess it's not.

I really welcome this update. Preware is awesome, as is webOS Quick Install. This should make things much easier, and hopefully will make the process of applying and removing patches easier for all of us.

I couldn't tell from Rod's instructions. Do I update Preware or the Package Manager Service first?

Package manager first, wait for java to restart (the evdo icon to come back,) then install preware.

Psssst, ummmm, guys....I think....he was joking. :)

You can never tell...

;-)

-- Rod

Good form, sir. Good form.

Package Manager 1st

Actually, to upgrade patches you need to remove them first, then install the new version.

See step 11 in http://forums.precentral.net/webos-patches/208312-autopatch-transitionin... ;-)

-- Rod

not sure if this can even be done, bu t I noticed that preware has in its preferences an option to background auto update. Anyone know how to enable this?

In the Preware app, go into preferences. Scroll to the bottom and look for Background box. As you notice the Check Updates and Auto Install options are greyed out for the dev has not yet given this a go.

can anyone help me, i am new at this. I downloaded the new webos install sofware, for purposes of enabling forward messaging in my palm pre and possibly installing the virtual keyboard.

I am receiving a message indicating that i need to install a patch package "tweaking requires package manager gnu patch and disffstat" can anyone tell me where i can find these?

shoot, I saw the 2 package updates in preware. I updated to 0.9.3 first, then when I checked into preware again, all of the items have no numbers after them. I then use wosqi, and install gnu patch, and then package manager service, and reboot the phone, and all the feeds are there now. I wanted to know how important it is for someone to use the emergency patch recovery tool? to this date, I have yet to use it at this time.

at the same time I also wanted to say that my touchstone charging have been rather quirky. when I put it on the touchstone, it will charge, but when i look at it in the morning, it is not at 100%. I am trying to think whether or not the tweaks are messing this up. Can anyone shed some light?

Wait.. why is the screenshot black? Mine is still grey after updating..

you have to change the theme in the preferences in order to get the dark look

Check prefs. :)

It's a really cool forum if you red the upgrades...

cool. gonna hold off a day or two and just exhale as i've reinstalled patches twice since 1.2.0 and i kinda tired of doing that.

OK, figured as much. Just checling. Thanks.

Oohhh boy made a huge mistake, what should I do, I update the preware first everithing I can't use anything

Oohhh boy made a huge mistake, what should I do, I update the preware first everithing I can't use anything

Great instructions! Updated & reinstalled patches with no problem!

Oohhh boy made a huge mistake, what should I do, I update the preware first everithing I can't use anything

Oohhh boy made a huge mistake, what should I do, I update the preware first everithing I can't use anything

funny, I thought the big mistake was posting the same thing three times ;-)

Seriously tho, I think that is covered in the instructions.

Nice update now if we could only get Preware to load consistently.

anybody know the email address to contact someone at precentral aside from going through the contact link

I tried to update preware first, before the service package, now it doesn't want to run, need help!!! please

My preware continues to say "updating". Should it be updating this long....? It has been about 30 minutes. How can I resolve this?

not enough memory on the servers

yeah same... mine is stuck updating. I remember it used to do this several versions back.

My Preware keeps saying updating too for a long time. Why is it doing this. It was working fine earlier.

Rod,
Is it possible to allow Preware to understand patch dependencies and check the corresponding version of the Patch Manager service needed for any given Preware version. Ideally, Preware would mention the dependencies (ie: Package Manager and Luna Manager) and ask the user if they want to automatically install the prerequisites (Yes, Cancel). Most people will just answer "Yes" and those who enter "Cancel" will hopefully update the correct patches in the correct order before updating Preware.

--
Bob

This functionality is currently in alpha testing for Preware 0.9.4

-- Rod

Preware 0.9.4 (including package dependency support) is now released.

The server is operating fine, but only has 2GB of real memory allocated to it at the moment, and so the number of apache children is pegged at 200 concurrent connections. We're currently pushing 7Mb/sec out the Gb/sec pipes at osuosl.org ...

We're looking to see if we can reallocate more memory to it immediately. I have initiated a purchase of 16GB of extra server memory, but we need donations at http://www.webos-internals.org/wiki/WebOS_Internals:Site_support to help pay for the additional hardware.

-- Rod

OH...is that why it is taking forever to update? oh dear God...

Server response should be fine now - here is what happened: http://twitpic.com/kxhn0

-- Rod

damn preware keeps loading and won't do anything

how long is the preware gonna update? its has been 2 hrs or more...How long has it been for anyone else with this same issue?

If it's more than 5 minutes, close Preware and try again.

-- Rod

Hmm, sounds like a bunch of work and some potential problems. I think I will wait a couple days or until I decide I want to change something.

That would help smooth out the load at least ;-)

http://twitpic.com/kxhn0

-- Rod

I wondered what was up with this last night! I tried resetting, turning developer mode on and off w/resetting etc and finally it took on our two pres...I thought it was too long after waiting 10 minutes with it loading. I thought the problem at first was that I had installed the preware update before the other update...I then noticed the forum link and figured out how to fix that.

Patches dont even install for me...

I'll install one, and it doesn't change anything...for example the battery percentage on top, If I install that, it doesn't add the percentage, yet it says its installed, BUT if I install it using Quickinstall it works fine..

:(

u have to restart ur pre after u install a patch then it takes effect

I have restarted luna after I install a patch, you mean I have to restart the entire phone?

I'll try now...

potential problem?...i decided to run this last night...ran epr...all patches were removed except for keyboard and i didnt manually remove bc it was late and i wasnt thinking too clearly!...i dont why i did but i ran the installs anyways - package manager first then preware...after the updates i reinstalled all patches...keyboard still works...but i cannot find it under installed packages...it appears under list of everything...how do i remove it so i could reinstall it and have preware recognize its on my pre? i do not want this to cause an issue on the next webos update

Select it in the list of everything, and hit Remove.

-- Rod

can anyone help me, i am new at this. I downloaded the new webos install sofware, for purposes of enabling forward messaging in my palm pre and possibly installing the virtual keyboard.

I am receiving a message indicating that i need to install a patch package "tweaking requires package manager gnu patch and disffstat" can anyone tell me where i can find these?

i have WebOS Quick Installer and WebOS doctor installed on my computer. but when i run WebOS Quick Installer and try to connect it always says "device not found." what do i need to do to fix this, i cant download any homebrew apps or anything from this site.

My Preware takes about 15 min for updating and is still updating :)
It's the first start of this prog, but that can't be normal or what do you think?

It would be great if you could add a "remove all patches" option some where because it's kind of annoying having to remove all patches one by one when updates are available.

THANKS!!!

what about a app that lets you edit or make changes to photos like the one on the iphone would be great, bringing back the flash as a flashlight and some serious changes to the confrence call feature. Oh by the way could some one please let me know if there has been a fix to the my tether for 1.3 yet. please email me at ricky_0327@yahoo.com cause i never seem to get open replies here for some reason

Is there a new tether code to install for the 1.3?
Please email at aristla152@yahoo.com
thank you.

I've had preware on my phone and i thought it was a built in app but it came jailbroken when i got it!

i still want my dad to jailbreak his touchpad i have cydia it is awesome