Angry Birds for Pixi now available; Update: Lite versions also available | webOS Nation
 
 

Angry Birds for Pixi now available; Update: Lite versions also available

by Dieter Bohn Thu, 16 Sep 2010 11:43 am EDT

 

While it's a little unfortunate that it needs a separate entry from Angry Birds for the Palm Pre, Pixi and Pixi Plus owners should be gratified to know that they can now sling avians with the rest of us now that Angry Birds for Pixi has dropped. Check out our first-look video (Running on the Pre) after the break. 

Of course, you'll need webOS 1.4.5 to get it, which means that AT&T Palm Pixi Plus owners are left out of the action. We still love you, GSM Pixi folks, even if your carrier doesn't.

Update: Looking to get your Angry Birds on but can't stomach the $1.99 asking price (and really, really?), Rovio has also released Angry Birds Lite for Pre and Angry Birds Lite for Pixi.

Category: